<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Letter: Freeze on new missiles needed - Albert Lea Tribune | Albert Lea Tribune</title>

                <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1628535658" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1628535658" />
				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1628535658" />
				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1628535658" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/style.css?1628535658" />

        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1628535658"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/media/img/brand/favicon-albertlea.png">
				<link rel="apple-touch-icon" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																<meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Letter: Freeze on new missiles needed - Albert Lea Tribune" />
	<meta property="og:description" content="I’m not sure if hypersonic missiles or Iran’s drones have a chance of first strike capability. If so, or if some countries will think so, and/or don’t fear a second strike, then we need to take preventative steps. The same applies to nuclear weapons (with or without these) and perhaps likewise even poison gas. If [&hellip;]" />
	<meta property="og:url" content="https://m.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/" />
	<meta property="og:site_name" content="Albert Lea Tribune" />
	<meta property="article:published_time" content="2021-08-11T01:30:31+00:00" />
	<meta property="article:modified_time" content="2021-08-10T22:27:41+00:00" />
	<meta property="og:image" content="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="420" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Submitted">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://albertleatribune.com/#website","url":"https://albertleatribune.com/","name":"Albert Lea Tribune","description":"Local news, sports, weather, opinions, obituaries","potentialAction":[{"@type":"SearchAction","target":"https://albertleatribune.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/#primaryimage","inLanguage":"en-US","url":"https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg","width":800,"height":420},{"@type":"WebPage","@id":"https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/#webpage","url":"https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/","name":"Letter: Freeze on new missiles needed - Albert Lea Tribune","isPartOf":{"@id":"https://albertleatribune.com/#website"},"primaryImageOfPage":{"@id":"https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/#primaryimage"},"datePublished":"2021-08-11T01:30:31+00:00","dateModified":"2021-08-10T22:27:41+00:00","author":{"@id":"https://albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/"]}]},{"@type":"Person","@id":"https://albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6","name":"Submitted","image":{"@type":"ImageObject","@id":"https://albertleatribune.com/#personlogo","inLanguage":"en-US","url":"https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?w=96","caption":"Submitted"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.albertleatribune.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Albert Lea Tribune &raquo; Letter: Freeze on new missiles needed Comments Feed" href="https://m.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.albertleatribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.albertleatribune.com/_static/??-eJyNjF0KAjEMhC9kN6jr34N4ljYNGjdtl6aL9vYWQVkRwbeZ+WYGbqPhiDJ5UkBV8FYvjClqFzh2LVnAvHJVKI0PLt3f4rv1PGIt4CThYIRdtrmClir08zeQZ0tCgWL5MKPYStkInS3W/+aNzf1rdArH5Xa13/S7/rB+AJHdXSM=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.albertleatribune.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.albertleatribune.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.8' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.albertleatribune.com/wp-includes/css/admin-bar.min.css?m=1628547493g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.albertleatribune.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.albertleatribune.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.albertleatribune.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.8' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/style.css?ver=1628535658' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.albertleatribune.com/wp-content/mu-plugins/jetpack-10.0/css/jetpack.css?ver=10.0' media='all' />
<script type='text/javascript' src='https://m.albertleatribune.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZkYWpibmJpXEWAK+hIik='></script>
<link rel="https://api.w.org/" href="https://m.albertleatribune.com/wp-json/" /><link rel="alternate" type="application/json" href="https://m.albertleatribune.com/wp-json/wp/v2/posts/762244" /><link rel='shortlink' href='https://m.albertleatribune.com/?p=762244' />
<link rel="alternate" type="application/json+oembed" href="https://m.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.albertleatribune.com%2F2021%2F08%2Fletter-freeze-on-new-missiles-needed%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.albertleatribune.com%2F2021%2F08%2Fletter-freeze-on-new-missiles-needed%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style>
		<meta name="google-site-verification" content="V_GdI8BpuhtAvIqQr_W1pg0sDroZdM_rzcMHst2Vs38" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4352474-1', 'auto');
  ga('send', 'pageview');

</script>

<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.albertleatribune.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

					
					_bwtp = new TheWall('https://subscriptions.albertleatribune.com/bwtw/', 'ALT', 'ALT', null, 'DEFAULT');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0.5em; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border: 1px solid #aaa; text-align: center; color: #222;">' +
									'<p>Thank you for supporting local journalism and your community.<br />' +
									'We hope you enjoy ' + pw_total_val + ' free stories each month.<br />'+
									'We offer two options if you need more stories. You can get unlimited access for an entire month for just $6 a month; or a 24-hour period for just .99 cents.</p>'+
									'<p><strong><a href="https://subscriptions.albertleatribune.com/CircStore/daypass" style="color: #92191f;">One-Day Pass:</a></strong> Get unlimited access for 24-hours without annoying pop ups, for only .99 cents.</p>'  +
									'<p><strong><a href="https://subscriptions.albertleatribune.com/circstore" style="color: #92191f;">Digital Subscription:</a></strong> Enjoy unlimited digital access (includes the complete electronic edition) for only $6 per month.</p>'+
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
              }

						} else {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/ALNI-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/ALNI-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/ALNI-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/ALNI-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/ALNI-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/ALNI-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/ALNI-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

                  googletag.pubads().setTargeting("catname", [ "letterstoeditor", "opinion",  ]);
          
          googletag.pubads().setTargeting("pageurl", "/2021/08/letter-freeze-on-new-missiles-n");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/ALNI-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/ALNI-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/ALNI-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/ALNI-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/ALNI-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/ALNI-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/ALNI-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/ALNI-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/ALNI-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/ALNI-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/ALNI-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/ALNI-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/ALNI-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/ALNI-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/ALNI-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/ALNI-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/ALNI-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/ALNI-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/ALNI-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/ALNI-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-leader', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-4', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-5', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-6', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-sticky', mt_in_view, mt_on_page, [['refresh', 'true']]],
      ]);
  </script>
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/pndM4AxNqR8GTouy9whV51KEs4jW17f4LeUmmFLafWDs7rGxUw0ekVgT_O2T3YfAskC1t86bnrIqSw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        
    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=32686506'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.albertleatribune.com">
						<img class="logo" src="https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/media/img/brand/logo-white-albertlea.png" alt="Albert Lea Tribune" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.albertleatribune.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Albert Lea Tribune..." onfocus="if(this.value=='Search Albert Lea Tribune...'){this.value='';}" onblur="if(this.value==''){this.value='Search Albert Lea Tribune...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
							<ul id="supNav">
	<li class=""><a href="https://m.albertleatribune.com/contests/" title="" rel="nofollow">Contests</a></li>
	<li><a href="https://m.albertleatribune.com/category/albertleamagazine" rel="bookmark">A.L. Magazine</a></li>
	<li><a href="https://m.albertleatribune.com/category/weather" rel="bookmark">Weather</a></li>
	<li><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea" rel="bookmark">Classifieds</a></li>
	<li class="public-notices"><a href="https://m.albertleatribune.com/category/public-notices/" rel="bookmark">Public Notices</a></li>
  <li><a href="https://www.facebook.com/albertleatribune" rel="bookmark">Facebook</a></li>
	<li class="">
		<a href="https://m.albertleatribune.com/services/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://m.albertleatribune.com/services/submit-a-news-tip/" title="" rel="nofollow">Send: News tip</a></li>
			<li><a href="https://m.albertleatribune.com/services/submit-a-calendar-event/" title="" rel="nofollow">Send: Calendar event</a></li>
			<li><a href="https://m.albertleatribune.com/send-a-video-form/" title="" rel="nofollow">Send: Video</a></li>
			<li><a href="https://m.albertleatribune.com/services/submit-a-photo/" title="" rel="nofollow">Send: Photo</a></li>
			<li><a href="https://m.albertleatribune.com/photo-order-form/" title="" rel="nofollow">Order: Photo</a></li>
			<li><a href="https://m.albertleatribune.com/services/letters-to-editor" title="" rel="nofollow">Send: Letter to the Editor</a></li>
			<li><a href="https://m.albertleatribune.com/services/birth-announcement/" title="" rel="nofollow">Send: Birth announcement</a></li>
			<li><a href="https://m.albertleatribune.com/services/engagement-announcement/" title="" rel="nofollow">Send: Engagement announcement</a></li>
			<li><a href="https://m.albertleatribune.com/services/wedding-announcement/" title="" rel="nofollow">Send: Wedding announcement</a></li>
		</ul>
	</li>
	<li class="subscribe"><a href="https://m.albertleatribune.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
	<li class="e-edition"><a href="https://subscriptions.albertleatribune.com/CircStore/Account/Login?vendor=DirXion&prodId=ALT" title="" rel="nofollow">E-Edition</a></li>
</ul>							<p class="date">
								August 11, 2021							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class="home "><a href="https://m.albertleatribune.com">Home</a></li>
	<li class="news "><a href="https://m.albertleatribune.com/category/news/">News</a></li>
	<li class="progress "><a href="https://m.albertleatribune.com/category/progress-2021/">Progress</a></li>
	<li class="health-updates"><a href="https://m.albertleatribune.com/category/health-updates/">Health Updates</a></li>
	<li class="sports"><a href="https://m.albertleatribune.com/category/sports/">Sports</a></li>
	<li class="opinion"><a href="https://m.albertleatribune.com/category/opinion/">Opinion</a></li>
	<li class="lifestyle"><a href="https://m.albertleatribune.com/category/lifestyles/">Arts &amp; Culture</a></li>
  	<li class="obits"><a href="https://m.albertleatribune.com/category/obituaries/">Obits</a></li>
	<li class="extras"><a href="">Extras</a></li>
	<li class="services"><a href="https://m.albertleatribune.com/services/about-us/">Services</a></li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

	
							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.albertleatribune.com/2021/08/letter-council-needs-to-highlight-citys-value-and-bring-in-growth/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://m.albertleatribune.com/2021/08/letter-council-needs-to-highlight-citys-value-and-bring-in-growth/">
              <img src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://m.albertleatribune.com/2021/08/letter-council-needs-to-highlight-citys-value-and-bring-in-growth/">Letter: Council needs to highlight city’s value and bring&hellip;</a> </h4>
          <a href="https://m.albertleatribune.com/2021/08/letter-council-needs-to-highlight-citys-value-and-bring-in-growth/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img width="622" height="327" src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?w=622" class="attachment-story-photo size-story-photo wp-post-image" alt="" loading="lazy" srcset="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg 800w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?resize=300,158 300w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?resize=768,403 768w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?resize=622,327 622w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/08/LTE.jpg?resize=398,208 398w" sizes="(max-width: 622px) 100vw, 622px" /></dt><dd class='wp-caption-text'></dd></dl>

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Letter: Freeze on new missiles needed</h2>

										<div class="byline">
											
											<a href="https://m.albertleatribune.com/author/Submitted_albertlea/" rel="bookmark">
                        <img width="120" height="120" src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?w=120" class="avatar avatar-120 photo" alt="" loading="lazy" srcset="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg 800w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=150,150 150w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=300,300 300w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=768,768 768w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=622,622 622w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=350,350 350w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=90,90 90w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=45,45 45w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=24,24 24w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=48,48 48w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?resize=96,96 96w" sizes="(max-width: 120px) 100vw, 120px" />											</a>

											<p class="author">
												<strong>By <a href="https://m.albertleatribune.com/author/Submitted_albertlea/" rel="bookmark">Submitted</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:lifestyles@albertleatribune.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 8:30 pm Tuesday, August 10, 2021</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Letter: Freeze on new missiles needed. I\u2019m not sure if hypersonic missiles or Iran\u2019s drones have a chance of first strike capability. If so, or if some countries will think so, and\/or don\u2019t fear a second strike, then we need to take preventative steps. The same applies to nuclear weapons (with or without these) and perhaps likewise even poison gas.\r\nIf there is a chance of conquest by China, Iran or North Korea \u2014 or a chance of destruction by any of those countries or by Russia, we need a freeze on new missiles and\/or weapons of those sorts; there should be immediate inspection of any suspicious sites in order to verify this. (If they don\u2019t fear a second strike or would furnish to terrorists, we need to have them dismantle what they already have \u2014 again with immediate inspection.)\r\nPerhaps the way to do this is by offering and\/or establishing increased trade while threatening increased sanctions, with the spread wide enough so that they won\u2019t want to chance our missing any of the sites.\r\n(For Russia, we might also try diplomacy like a NATO invitation. Alternatively, increased economic ties might forestall destruction. For North Korea, perhaps we might also give them a choice between de-nuclearizing the Korean peninsula or putting enough arms in South Korea and nearby to destroy them.)\r\nPerhaps we can bring about human rights, such as freedom of religion; and perhaps we can get China to stop supporting North Korea if nothing else works with the latter.\r\nAlvin Blake\r\nAlbert Lea","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=90062493dbbaa336e8a11ca588796390&postHash=4ee6ed23f6c88b6a249231bc90f07fb5&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p><span class="s1">I’m not sure if hypersonic missiles or Iran’s drones have a chance of first strike capability. If so, or if some countries will think so, and/or don’t fear a second strike, then we need to take preventative steps. The same applies to nuclear weapons (with or without these) and perhaps likewise even poison gas.</span></p>
<p><span class="s1">If there is a chance of conquest by China, Iran or North Korea — or a chance of destruction by any of those countries or by Russia, we need a freeze on new missiles and/or weapons of those sorts; there should be immediate inspection of any suspicious sites in order to verify this. (If they don’t fear a second strike or would furnish to terrorists, we need to have them dismantle what they already have — again with immediate inspection.)</span></p>
<div id='mydfpad' class='ad300x ad'>
            <div id='div-gpt-ad-bigblock-1'>
              <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
              </script>
            </div>
          </div>
          <div id='cedato-unit'></div><p><span class="s1">Perhaps the way to do this is by offering and/or establishing increased trade while threatening increased sanctions, with the spread wide enough so that they won’t want to chance our missing any of the sites.</span></p>
<p><span class="s1">(For Russia, we might also try diplomacy like a NATO invitation. Alternatively, increased economic ties might forestall destruction. For North Korea, perhaps we might also give them a choice between de-nuclearizing the Korean peninsula or putting enough arms in South Korea and nearby to destroy them.)</span></p>
<div id='mydfpad3' class='ad300x ad'>
                  <div id='div-gpt-ad-bigblock-2'>
                    <script>
                      googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
                    </script>
                  </div>
                  </div><p><span class="s1">Perhaps we can bring about human rights, such as freedom of religion; and perhaps we can get China to stop supporting North Korea if nothing else works with the latter.</span></p>
<div id='mydfpad4' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p><span class="s1"><b>Alvin Blake</b></span></p>
<p><span class="s1">Albert Lea</span></p>
<div id='mydfpad2' class='ad300x ad'>
          <div id='div-gpt-ad-bigblock-3'>
            <script>
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
            </script>
          </div>
          </div>
                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>

	              
<div class="more_to_explore">
  <h4>More News</h4>

  
        <div class="story">
                    <a href="https://m.albertleatribune.com/2021/08/emerald-ash-borer-confirmed-in-worth-winnebago-counties/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2011/05/EmeraldAshborer.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.albertleatribune.com/2021/08/emerald-ash-borer-confirmed-in-worth-winnebago-counties/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Emerald ash borer confirmed in Worth, Winnebago counties">Emerald ash borer confirmed in Worth, Winnebago counties</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.albertleatribune.com/2021/08/5-things-to-do-this-week-25/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2021/07/5ThingsToDo.2.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.albertleatribune.com/2021/08/5-things-to-do-this-week-25/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="5 things to do this week">5 things to do this week</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.albertleatribune.com/2021/08/glenville-days-happening-this-weekend/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.albertleatribune.com/wp-content/uploads/sites/14/2017/06/0612-Glenville-Days-4.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.albertleatribune.com/2021/08/glenville-days-happening-this-weekend/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Glenville Days happening this weekend">Glenville Days happening this weekend</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://m.albertleatribune.com/2021/08/editorial-take-a-break-sit-down-and-enjoy-reading-a-book/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Editorial: Take a break, sit down and enjoy reading a book">Editorial: Take a break, sit down and enjoy reading a book</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>
        <ul class="sidebar">
                    </ul>
	

                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134049"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
    

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



												

<div id="disqus_thread"></div>

<script>
    /**
    * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
    * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
    */
    /*
    */
    var disqus_config = function () {
      //this.page.url = 'https://m.albertleatribune.com/2021/08/letter-freeze-on-new-missiles-needed/';
      this.page.identifier = '762244 https://m.albertleatribune.com/?p=762244';
      this.page.title = 'Letter: Freeze on new missiles needed - Albert Lea Tribune';
    };
    (function() { // DON'T EDIT BELOW THIS LINE
    var d = document, s = d.createElement('script');

    s.src = '//albertleatribune.disqus.com/embed.js';

    s.setAttribute('data-timestamp', +new Date());
    (d.head || d.body).appendChild(s);
    })();
</script>
  <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>



									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Opinion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/editorial-take-a-break-sit-down-and-enjoy-reading-a-book/" title="Permalink to Editorial: Take a break, sit down and enjoy reading a book" rel="bookmark">Editorial: Take a break, sit down and enjoy reading a book</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/my-point-of-view-there-is-much-more-to-be-done-to-address-systemic-racism/" title="Permalink to My Point of View: There is much more to be done to address systemic racism" rel="bookmark">My Point of View: There is much more to be done to address systemic racism</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/sarah-stultz-another-school-year-is-right-around-the-corner/" title="Permalink to Sarah Stultz: Another school year is right around the corner" rel="bookmark">Sarah Stultz: Another school year is right around the corner</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/ask-a-trooper-rumor-about-interstate-is-hard-to-dispel/" title="Permalink to Ask a Trooper: Rumor about interstate is hard to dispel" rel="bookmark">Ask a Trooper: Rumor about interstate is hard to dispel</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/al-batt-i-felt-as-lucky-as-kentucky-on-a-fair-day-this-season/" title="Permalink to Al Batt: I felt as lucky as Kentucky on a fair day this season" rel="bookmark">Al Batt: I felt as lucky as Kentucky on a fair day this season</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Sports</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/green-lea-crowns-club-tournament-champions/" title="Permalink to Green Lea crowns club tournament champions" rel="bookmark">Green Lea crowns club tournament champions</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/iowa-to-add-shot-clocks-to-boys-and-girls-basketball-starting-in-2022-23/" title="Permalink to Iowa to add shot clocks to boys and girls basketball starting in 2022-23" rel="bookmark">Iowa to add shot clocks to boys and girls basketball starting in 2022-23</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/tiger-tennis-begins-practices/" title="Permalink to Tiger tennis begins practices" rel="bookmark">Tiger tennis begins practices</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/progress-slow-for-vikes-rookie-darrisaw-line-still-in-flux/" title="Permalink to Progress slow for Vikes rookie Darrisaw; line still in flux" rel="bookmark">Progress slow for Vikes rookie Darrisaw; line still in flux</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/jimenez-again-hits-2-home-runs-white-sox-rout-twins-11-1/" title="Permalink to Jiménez again hits 2 home runs, White Sox rout Twins 11-1" rel="bookmark">Jiménez again hits 2 home runs, White Sox rout Twins 11-1</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  		
		<li id="recent-posts-3" class="widget widget_recent_entries">
		<h2 class="widgettitle">Latest Stories</h2>

		<ul>
											<li>
					<a href="https://m.albertleatribune.com/2021/08/emerald-ash-borer-confirmed-in-worth-winnebago-counties/">Emerald ash borer confirmed in Worth, Winnebago counties</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2021/08/5-things-to-do-this-week-25/">5 things to do this week</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2021/08/glenville-days-happening-this-weekend/">Glenville Days happening this weekend</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2021/08/editorial-take-a-break-sit-down-and-enjoy-reading-a-book/">Editorial: Take a break, sit down and enjoy reading a book</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2021/08/my-point-of-view-there-is-much-more-to-be-done-to-address-systemic-racism/">My Point of View: There is much more to be done to address systemic racism</a>
									</li>
					</ul>

		</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Style</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/robin-gudal-connecting-with-faith-through-song/" title="Permalink to Robin Gudal: Connecting with faith through song" rel="bookmark">Robin Gudal: Connecting with faith through song</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/across-the-pastors-desk-following-the-golden-rule-be-kind/" title="Permalink to Across the Pastor&#8217;s Desk: Following the Golden Rule; be kind" rel="bookmark">Across the Pastor&#8217;s Desk: Following the Golden Rule; be kind</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/sweet-ideas-for-easy-back-to-school-breakfasts/" title="Permalink to Sweet ideas for easy back-to-school breakfasts" rel="bookmark">Sweet ideas for easy back-to-school breakfasts</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/07/guest-column-farmers-market-week-will-be-celebrated-at-albert-lea-market-second-week-in-august/" title="Permalink to Guest Column: Farmers Market Week will be celebrated at Albert Lea market second week in August" rel="bookmark">Guest Column: Farmers Market Week will be celebrated at Albert Lea market second week in August</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/07/across-the-pastors-desk-compassion-comes-in-many-forms/" title="Permalink to Across the Pastor&#8217;s Desk: Compassion comes in many forms" rel="bookmark">Across the Pastor&#8217;s Desk: Compassion comes in many forms</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Business</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/06/exp-realty-welcomes-new-agent/" title="Permalink to eXp Realty welcomes new agent" rel="bookmark">eXp Realty welcomes new agent</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/03/chance-of-a-lifetime-2/" title="Permalink to Chance of a lifetime" rel="bookmark">Chance of a lifetime</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/03/34-freeborn-county-businesses-received-grants-through-state-relief-program/" title="Permalink to 34 Freeborn County businesses received grants through state relief program" rel="bookmark">34 Freeborn County businesses received grants through state relief program</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/03/deal-brewing-on-quick-tax-relief-bill-in-minnesota/" title="Permalink to Deal brewing on quick tax relief bill in Minnesota" rel="bookmark">Deal brewing on quick tax relief bill in Minnesota</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/03/its-an-industry-thats-always-going-to-be-there/" title="Permalink to ‘It’s an industry that’s always going to be there&#8217;" rel="bookmark">‘It’s an industry that’s always going to be there&#8217;</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Local News</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/emerald-ash-borer-confirmed-in-worth-winnebago-counties/" title="Permalink to Emerald ash borer confirmed in Worth, Winnebago counties" rel="bookmark">Emerald ash borer confirmed in Worth, Winnebago counties</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/5-things-to-do-this-week-25/" title="Permalink to 5 things to do this week" rel="bookmark">5 things to do this week</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/glenville-days-happening-this-weekend/" title="Permalink to Glenville Days happening this weekend" rel="bookmark">Glenville Days happening this weekend</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/marriage-licenses-july-2021/" title="Permalink to Marriage licenses: July 2021" rel="bookmark">Marriage licenses: July 2021</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2021/08/usda-offers-disaster-assistance-to-freeborn-county-livestock-producers-impacted-by-drought/" title="Permalink to USDA offers disaster assistance to Freeborn County livestock producers impacted by drought" rel="bookmark">USDA offers disaster assistance to Freeborn County livestock producers impacted by drought</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<div class="teaseStory special_sections_block">
			<h3 class="section">Special Section</h3>
      <iframe src="https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&amp;theme=theme2&amp;rows=2&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=false&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true](https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&theme=theme2&rows=2&thumbSize=large&roundedCorners=false&showTitle=false&showAuthor=false&shadow=true&effect3d=true)" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="100%" height="370"></iframe>

			<div class="more_stories">
				<h4><a href="https://www.albertleatribune.com/special-promos/" class="moreLink" rel="bookmark">More special sections</a></h4>
			</div>
		</div>

			<h3 class="section">Financials</h3>

			<div id="twitterBox300x" class="clearFix">
			<!--START theFinancials.com Content-->
			<!--copyright theFinancials.com - All Rights Reserved-->
			<iframe src='https://www.thefinancials.com/free/EXm_MarketUpdate_US.html' width='100%' marginheight='0' marginwidth='0' height='400' hspace='0' vspace='0' frameborder='no' style='margin-bottom:12px' title='US Market Update'><br /></iframe>
			<!--END theFinancials.com Content-->
			<br />
</div></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/emerald-ash-borer-confirmed-in-worth-winnebago-counties/" rel="bookmark" title="Emerald ash borer confirmed in Worth, Winnebago counties">Emerald ash borer confirmed in Worth, Winnebago counties</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/5-things-to-do-this-week-25/" rel="bookmark" title="5 things to do this week">5 things to do this week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/glenville-days-happening-this-weekend/" rel="bookmark" title="Glenville Days happening this weekend">Glenville Days happening this weekend</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/marriage-licenses-july-2021/" rel="bookmark" title="Marriage licenses: July 2021">Marriage licenses: July 2021</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/usda-offers-disaster-assistance-to-freeborn-county-livestock-producers-impacted-by-drought/" rel="bookmark" title="USDA offers disaster assistance to Freeborn County livestock producers impacted by drought">USDA offers disaster assistance to Freeborn County livestock producers impacted by drought</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/class-of-1951-reunion-approaching/" rel="bookmark" title="Class of 1951 reunion approaching">Class of 1951 reunion approaching</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/creativity-abounds-for-bucket-of-junk-contest-at-the-fair/" rel="bookmark" title="Creativity abounds for Bucket of Junk contest at the fair">Creativity abounds for Bucket of Junk contest at the fair</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/big-win-for-1t-infrastructure-bill-democrats-gop-come-together/" rel="bookmark" title="Big win for $1T infrastructure bill: Democrats, GOP come together">Big win for $1T infrastructure bill: Democrats, GOP come together</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/mercyone-to-require-covid-19-vaccine-for-medical-staff-colleagues-as-variant-spreads/" rel="bookmark" title="MercyOne to require COVID-19 vaccine for medical staff, colleagues as variant spreads">MercyOne to require COVID-19 vaccine for medical staff, colleagues as variant spreads</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/council-votes-to-acquire-14-tax-forfeited-properties/" rel="bookmark" title="Council votes to acquire 14 tax-forfeited properties">Council votes to acquire 14 tax-forfeited properties</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/group-sues-for-right-to-carry-guns-at-minnesota-state-fair/" rel="bookmark" title="Group sues for right to carry guns at Minnesota State Fair">Group sues for right to carry guns at Minnesota State Fair</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/minnesota-logs-5600-breakthrough-covid-19-cases-57-deaths/" rel="bookmark" title="Minnesota logs 5,600 breakthrough COVID-19 cases, 57 deaths">Minnesota logs 5,600 breakthrough COVID-19 cases, 57 deaths</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/dairyland-power-issues-peak-alert/" rel="bookmark" title="Peak energy alert issued">Peak energy alert issued</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/walz-to-lead-trade-mission-to-england-finland-in-november/" rel="bookmark" title="Walz to lead trade mission to England, Finland in November">Walz to lead trade mission to England, Finland in November</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Cops, Courts &amp; Fires</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/shed-broken-into-and-other-reports/" rel="bookmark" title="Shed broken into and other reports">Shed broken into and other reports</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/council-awards-6-9m-water-tower-contract/" rel="bookmark" title="Council awards $6.9M water tower contract">Council awards $6.9M water tower contract</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/university-of-minnesota-shifts-will-require-covid-shots/" rel="bookmark" title="University of Minnesota shifts, will require COVID shots">University of Minnesota shifts, will require COVID shots</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/canada-reopens-its-border-for-vaccinated-us-visitors/" rel="bookmark" title="Canada reopens its border for vaccinated US visitors">Canada reopens its border for vaccinated US visitors</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/demolition-derby-caps-off-fair-week/" rel="bookmark" title="Demolition derby caps off fair week">Demolition derby caps off fair week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/new-covid-19-death-reported-in-freeborn-county/" rel="bookmark" title="New COVID-19 death reported in Freeborn County">New COVID-19 death reported in Freeborn County</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Cops, Courts &amp; Fires</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/cars-broken-into-at-fair-and-other-reports/" rel="bookmark" title="Cars broken into at fair and other reports">Cars broken into at fair and other reports</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/much-of-minnesota-sees-rain-but-not-enough-to-break-drought/" rel="bookmark" title="Much of Minnesota sees rain, but not enough to break drought">Much of Minnesota sees rain, but not enough to break drought</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/newsboys-united-takes-over-grandstand-at-fair/" rel="bookmark" title="Newsboys United takes over Grandstand at fair">Newsboys United takes over Grandstand at fair</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2021/08/gallery-4-h-livestock-auction-at-the-fair/" rel="bookmark" title="Gallery: 4-H livestock auction at the fair">Gallery: 4-H livestock auction at the fair</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
														<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.albertleatribune.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/lifestyles/" title="" rel="bookmark"><span>Arts &amp; Culture</span></a></li>
								<li><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea" title="" rel="bookmark"><span>Classifieds</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
														<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://m.albertleatribune.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://m.albertleatribune.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://m.albertleatribune.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://m.albertleatribune.com/services/policies/#termsofuse" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://m.albertleatribune.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://m.albertleatribune.com/services/submit-a-photo/" title="" rel="nofollow">Submit a photo</a></li>
																							</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2021, Albert Lea Tribune</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1628535658"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1628535658"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1628535658"></script>

        

	
				
<script type="text/javascript">tb_pathToImage = "https://m.albertleatribune.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.albertleatribune.com/wp-includes/js/thickbox/tb-close.png";</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.albertleatribune.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/thickbox/thickbox.js?m=1628547493g'></script>
<script src='https://www.albertleatribune.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/hoverintent-js.min.js?m=1628547493g'></script>
<script src='https://m.albertleatribune.com/wp-includes/js/admin-bar.min.js?ver=5.8' id='admin-bar-js'></script>
<script id='admin-bar-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/m.albertleatribune.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.albertleatribune.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3' id='wp-polls-js'></script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/wp-embed.min.js?m=1628547493g'></script>
<script src='https://stats.wp.com/e-202132.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'173113710',post:'762244',tz:'-5',srv:'m.albertleatribune.com'} ]);
	_stq.push([ 'clickTrackerInit', '173113710', '762244' ]);
</script>
				</div><!-- END undertone -->
        				<script id="dsq-count-scr" src="//albertleatribune.disqus.com/count.js" async></script>
            </body>
</html>