<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Terry Larsen, 67 - Albert Lea Tribune | Albert Lea Tribune</title>

        <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1592988658" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1592988658" />
				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1592988658" />
				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1595866033" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/style.css?1593786575" />

        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1592988658"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/media/img/brand/favicon-albertlea.png">
				<link rel="apple-touch-icon" href="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																
<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.albertleatribune.com/2020/07/terry-larsen-67/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Terry Larsen, 67 - Albert Lea Tribune" />
<meta property="og:description" content="Terry Larsen, a native and resident of Albert Lea Minnesota, passed away Friday 24 July 2020. Born Thursday 12 Feb 1953, Terry was the fourth of 6 sons of Marilyn (Ellis) Larsen and LeRoy Larsen. A 1972 graduate of Albert Lea High School, he excelled in football, track and chorus. After graduating, Terry loved his &hellip;" />
<meta property="og:url" content="https://m.albertleatribune.com/2020/07/terry-larsen-67/" />
<meta property="og:site_name" content="Albert Lea Tribune" />
<meta property="article:section" content="NO PAYWALL" />
<meta property="article:published_time" content="2020-07-27T16:24:03-05:00" />
<meta property="og:image" content="https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?w=225" />
<meta property="og:image:secure_url" content="https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?w=225" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Terry Larsen, a native and resident of Albert Lea Minnesota, passed away Friday 24 July 2020. Born Thursday 12 Feb 1953, Terry was the fourth of 6 sons of Marilyn (Ellis) Larsen and LeRoy Larsen. A 1972 graduate of Albert Lea High School, he excelled in football, track and chorus. After graduating, Terry loved his [&hellip;]" />
<meta name="twitter:title" content="Terry Larsen, 67 - Albert Lea Tribune" />
<meta name="twitter:image" content="https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?w=225" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://m.albertleatribune.com/#website","url":"https://m.albertleatribune.com/","name":"Albert Lea Tribune","potentialAction":{"@type":"SearchAction","target":"https://m.albertleatribune.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://m.albertleatribune.com/2020/07/terry-larsen-67/#primaryimage","url":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?w=225"},{"@type":"WebPage","@id":"https://m.albertleatribune.com/2020/07/terry-larsen-67/#webpage","url":"https://m.albertleatribune.com/2020/07/terry-larsen-67/","inLanguage":"en-US","name":"Terry Larsen, 67 - Albert Lea Tribune","isPartOf":{"@id":"https://m.albertleatribune.com/#website"},"primaryImageOfPage":{"@id":"https://m.albertleatribune.com/2020/07/terry-larsen-67/#primaryimage"},"datePublished":"2020-07-27T16:24:03-05:00","dateModified":"2020-07-27T16:24:03-05:00","author":{"@id":"https://m.albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6"}},{"@type":["Person"],"@id":"https://m.albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6","name":"Submitted","image":{"@type":"ImageObject","@id":"https://m.albertleatribune.com/#authorlogo","url":"https://secure.gravatar.com/avatar/6b1017d1483f52c5d935e3e2858b666e?s=96&d=mm&r=g","caption":"Submitted"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.albertleatribune.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Albert Lea Tribune &raquo; Terry Larsen, 67 Comments Feed" href="https://m.albertleatribune.com/2020/07/terry-larsen-67/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.albertleatribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.albertleatribune.com/_static/??-eJxljG0LQDAURv+QuSFjH+S32CjX3uRO7N9bipRvT+c5HThWhk6ZfZwIFBGMA82ovKPcossTyeCrLAQh/Vr68x1/6w4hBZDGK80Mym3YIlCIZnq6ve2KWpQtr0TDL276MQ0=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.albertleatribune.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.albertleatribune.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.albertleatribune.com/wp-includes/css/admin-bar.min.css?m=1592863976g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.albertleatribune.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.albertleatribune.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.albertleatribune.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/style.css?ver=1592988658' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.albertleatribune.com/wp-content/mu-plugins/jetpack/css/jetpack.css?ver=8.7.1' media='all' />
<script src='https://m.albertleatribune.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1592863976g'></script>
<link rel='https://api.w.org/' href='https://m.albertleatribune.com/wp-json/' />
<link rel='shortlink' href='https://m.albertleatribune.com/?p=742142' />
<link rel="alternate" type="application/json+oembed" href="https://m.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.albertleatribune.com%2F2020%2F07%2Fterry-larsen-67%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.albertleatribune.com%2F2020%2F07%2Fterry-larsen-67%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><meta name="google-site-verification" content="V_GdI8BpuhtAvIqQr_W1pg0sDroZdM_rzcMHst2Vs38" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4352474-1', 'auto');
  ga('send', 'pageview');

</script>

<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.albertleatribune.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

					
					_bwtp = new TheWall('https://subscriptions.albertleatribune.com/bwtw/', 'ALT', 'ALT', null, 'NOPAYWALL');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0.5em; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border: 1px solid #aaa; text-align: center; color: #222;">' +
									'<p>Thank you for supporting local journalism and your community.<br />' +
									'We hope you enjoy ' + pw_total_val + ' free stories each month.<br />'+
									'We offer two options if you need more stories. You can get unlimited access for an entire month for just $6 a month; or a 24-hour period for just .99 cents.</p>'+
									'<p><strong><a href="https://subscriptions.albertleatribune.com/CircStore/daypass" style="color: #92191f;">One-Day Pass:</a></strong> Get unlimited access for 24-hours without annoying pop ups, for only .99 cents.</p>'  +
									'<p><strong><a href="https://subscriptions.albertleatribune.com/circstore" style="color: #92191f;">Digital Subscription:</a></strong> Enjoy unlimited digital access (includes the complete electronic edition) for only $6 per month.</p>'+
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
              }

						} else {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script src="https://storage.googleapis.com/didna-files/utility/didna_logging_util.min.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>

<!-- Invisibly Pixel Code -->
<script>
 window.ia = window.ia || function (){
 (window.ia.q = window.ia.q || []).push(arguments); };
 ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script >docReady(function(){ ims.startServices(); });</script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>
googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/ALNI-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/ALNI-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/ALNI-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/ALNI-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/ALNI-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/ALNI-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/ALNI-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

          googletag.pubads().setTargeting("catname", "no-paywall");
    
          googletag.pubads().setTargeting("pageurl", "/2020/07/terry-larsen-67/");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/ALNI-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/ALNI-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/ALNI-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/ALNI-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/ALNI-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/ALNI-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/ALNI-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/ALNI-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/ALNI-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/ALNI-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/ALNI-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/ALNI-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/ALNI-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/ALNI-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/ALNI-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/ALNI-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/ALNI-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/ALNI-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/ALNI-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/ALNI-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/pndM4AxNqR8GTouy9whV51KEs4jW17f4LeUmmFLafWDs7rGxUw0ekVgT_O2T3YfAskC1t86bnrIqSw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>

    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.albertleatribune.com/2020/07/terry-larsen-67/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=32686506'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.albertleatribune.com">
						<img class="logo" src="https://www.albertleatribune.com/wp-content/themes/2016-albertlea-mobile-child/media/img/brand/logo-white-albertlea.png" alt="Albert Lea Tribune" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.albertleatribune.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Albert Lea Tribune..." onfocus="if(this.value=='Search Albert Lea Tribune...'){this.value='';}" onblur="if(this.value==''){this.value='Search Albert Lea Tribune...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
							<ul id="supNav">
	<li><a href="https://m.albertleatribune.com/category/albertleamagazine" rel="bookmark">A.L. Magazine</a></li>
	<li><a href="https://m.albertleatribune.com/category/weather" rel="bookmark">Weather</a></li>
	<li><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea" rel="bookmark">Classifieds</a></li>
	<li><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea/Home/Search?majorClass=2600" rel="bookmark">Public Notices</a></li>
  <li><a href="https://www.facebook.com/albertleatribune" rel="bookmark">Facebook</a></li>
	<li class="">
		<a href="https://m.albertleatribune.com/services/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://m.albertleatribune.com/services/submit-a-news-tip/" title="" rel="nofollow">Send: News tip</a></li>
			<li><a href="https://m.albertleatribune.com/services/submit-a-calendar-event/" title="" rel="nofollow">Send: Calendar event</a></li>
			<li><a href="https://m.albertleatribune.com/send-a-video-form/" title="" rel="nofollow">Send: Video</a></li>
			<li><a href="https://m.albertleatribune.com/services/submit-a-photo/" title="" rel="nofollow">Send: Photo</a></li>
			<li><a href="https://m.albertleatribune.com/photo-order-form/" title="" rel="nofollow">Order: Photo</a></li>
			<li><a href="https://m.albertleatribune.com/services/letters-to-editor" title="" rel="nofollow">Send: Letter to the Editor</a></li>
			<li><a href="https://m.albertleatribune.com/services/birth-announcement/" title="" rel="nofollow">Send: Birth announcement</a></li>
			<li><a href="https://m.albertleatribune.com/services/engagement-announcement/" title="" rel="nofollow">Send: Engagement announcement</a></li>
			<li><a href="https://m.albertleatribune.com/services/wedding-announcement/" title="" rel="nofollow">Send: Wedding announcement</a></li>
		</ul>
	</li>
	<li class="subscribe"><a href="https://m.albertleatribune.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
	<li class="e-edition"><a href="https://subscriptions.albertleatribune.com/CircStore/Account/Login?vendor=DirXion&prodId=ALT" title="" rel="nofollow">E-Edition</a></li>
</ul>							<p class="date">
								July 27, 2020							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class="home "><a href="https://m.albertleatribune.com">Home</a></li>
	<li class="news "><a href="https://m.albertleatribune.com/category/news/">News</a></li>
	<li class="progress "><a href="https://m.albertleatribune.com/category/progress-2019/">Progress</a></li>
	<li class="health-updates"><a href="https://m.albertleatribune.com/category/health-updates/">Health Updates</a></li>
	<li class="sports"><a href="https://m.albertleatribune.com/category/sports/">Sports</a></li>
	<li class="opinion"><a href="https://m.albertleatribune.com/category/opinion/">Opinion</a></li>
	<li class="lifestyle"><a href="https://m.albertleatribune.com/category/lifestyles/">Arts &amp; Culture</a></li>
  	<li class="obits"><a href="https://m.albertleatribune.com/category/obituaries/">Obits</a></li>
	<li class="extras"><a href="">Extras</a></li>
	<li class="services"><a href="https://m.albertleatribune.com/services/about-us/">Services</a></li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

<!-- Boone Newspaper DurationMedia -->
<script type='text/javascript' src='https://pr.realvu.net/flip/2/c=E404_f=site_si=976'></script>

							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.albertleatribune.com/2020/07/kathleen-mae-bennett/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                      <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <h4> <a href="https://m.albertleatribune.com/2020/07/kathleen-mae-bennett/">Kathleen Mae Bennett</a> </h4>
          <a href="https://m.albertleatribune.com/2020/07/kathleen-mae-bennett/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Terry Larsen, 67</h2>

										<div class="byline">
											
											<a href="https://m.albertleatribune.com/author/Submitted_albertlea/" rel="bookmark">
                        <img alt='' src='https://secure.gravatar.com/avatar/6b1017d1483f52c5d935e3e2858b666e?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6b1017d1483f52c5d935e3e2858b666e?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' />											</a>

											<p class="author">
												<strong>By <a href="https://m.albertleatribune.com/author/Submitted_albertlea/" rel="bookmark">Submitted</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:lifestyles@albertleatribune.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 11:24 am Monday, July 27, 2020</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Terry Larsen, 67. \r\n\r\nTerry Larsen, a native and resident of Albert Lea Minnesota, passed away Friday 24 July 2020.\r\n\r\n\r\n\r\nBorn Thursday 12 Feb 1953, Terry was the fourth of 6 sons of Marilyn (Ellis) Larsen and LeRoy Larsen. A 1972 graduate of Albert Lea High School, he excelled in football, track and chorus.\r\n\r\nAfter graduating, Terry loved his job manufacturing laminated wood beams at Weyerhaeuser Albert Lea. Leaving Albert Lea, he worked at a dairy operation near Caledonia Minnesota, a coal mine outside Gillette Wyoming and drove truck over icy mountain passes.\r\n\r\nReturning to Albert Lea, Terry married twice, first to Teresa Burke then to Eva Larsen. He and Eva became proud owners and operators of a successful floor cleaning company, serving large clients like Walmart.\r\n\r\nHaving no children, Terry pursued his deep passions of hunting and fishing. When Terry was young, the Albert Lea area abounded with excellent habitat for ducks and pheasants. He sat in cold marshlands awaiting ducks. He walked miles of fencerow for each pheasant, always accompanied by a beloved golden retriever. He intimately knew all the local fishing lakes including Fountain, Bear and Beaver. With or without a buddy, Terry loved hunting and fishing. He was quick to share a delicious meal of roast pheasant, BB\u2019s included.\r\n\r\nWe remember Terry for his soulful, angelic singing voice reminiscent of his mother. We remember his ridiculous tales of the one that got away. We remember his infectious laugh, his wild and free spirit. To the end, the world never tamed Terry Larsen.\r\n\r\nTerry is survived by wife Eva, brothers Ron (Judy), Denny (Sue), Gary, Mike (Linda) and Steve (Claire) and many cousins, nephews and nieces.\r\n\r\nHe is preceded in death by his mother, father and billions of others.\r\n\r\nPrivate memorial gatherings are planned. The family asks you to gather and memorialize Terry as you see fit. Memorial donations may be sent to Ducks Unlimited or Pheasants Forever.\r\n\r\n","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=90062493dbbaa336e8a11ca588796390&postHash=47c912db7ea7117840e9f3ada74f07f1&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><div class="modulist-rss--content-container">
<p>Terry Larsen, a native and resident of Albert Lea Minnesota, passed away Friday 24 July 2020.</p>
<div id="attachment_742143" style="width: 235px" class="wp-caption alignright"><img aria-describedby="caption-attachment-742143" class="size-medium wp-image-742143" src="https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?w=225" alt="" width="225" height="300" srcset="https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg 810w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?resize=225,300 225w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?resize=768,1024 768w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?resize=622,829 622w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?resize=263,350 263w, https://m.albertleatribune.com/wp-content/uploads/sites/14/2020/07/5f1ef3a826777951a0e84090-63nqp3.jpeg?resize=104,139 104w" sizes="(max-width: 225px) 100vw, 225px" /><p id="caption-attachment-742143" class="wp-caption-text">Terry Larsen</p></div>
<p>Born Thursday 12 Feb 1953, Terry was the fourth of 6 sons of Marilyn (Ellis) Larsen and LeRoy Larsen. A 1972 graduate of Albert Lea High School, he excelled in football, track and chorus.</p>
<p>After graduating, Terry loved his job manufacturing laminated wood beams at Weyerhaeuser Albert Lea. Leaving Albert Lea, he worked at a dairy operation near Caledonia Minnesota, a coal mine outside Gillette Wyoming and drove truck over icy mountain passes.</p>
<p>Returning to Albert Lea, Terry married twice, first to Teresa Burke then to Eva Larsen. He and Eva became proud owners and operators of a successful floor cleaning company, serving large clients like Walmart.</p>
<p>Having no children, Terry pursued his deep passions of hunting and fishing. When Terry was young, the Albert Lea area abounded with excellent habitat for ducks and pheasants. He sat in cold marshlands awaiting ducks. He walked miles of fencerow for each pheasant, always accompanied by a beloved golden retriever. He intimately knew all the local fishing lakes including Fountain, Bear and Beaver. With or without a buddy, Terry loved hunting and fishing. He was quick to share a delicious meal of roast pheasant, BB’s included.</p>
<p>We remember Terry for his soulful, angelic singing voice reminiscent of his mother. We remember his ridiculous tales of the one that got away. We remember his infectious laugh, his wild and free spirit. To the end, the world never tamed Terry Larsen.</p>
<div id='mydfpad3' class='ad300x ad'>
										<div id='div-gpt-ad-bigblock-2'>
											<script>
												googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
											</script>
										</div>
                    </div><p>Terry is survived by wife Eva, brothers Ron (Judy), Denny (Sue), Gary, Mike (Linda) and Steve (Claire) and many cousins, nephews and nieces.</p>
<p>He is preceded in death by his mother, father and billions of others.</p>
<p>Private memorial gatherings are planned. The family asks you to gather and memorialize Terry as you see fit. Memorial donations may be sent to Ducks Unlimited or Pheasants Forever.</p>
<div class="modulist-rss--image-container"></div>
</div>

                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>



                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134049"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
  

<div style="clear:both;">
<script>
!function(n){if(!window.cnx){window.cnx={},window.cnx.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document;c=n.createElement('script'),c.src='//cd.connatix.com/connatix.player.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="97fcfae9af944377a587c6aecda28e00">
  cnx.cmd.push(function() {
    cnx({
      playerId: 'b8b3adb8-39e6-4bca-8e9b-b12295f1fd23'
    }).render('97fcfae9af944377a587c6aecda28e00');
  });
</script>
</div>



												
<div id="disqus_thread"></div>
<script>
/**
* RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
* LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
*/
/*
*/
var disqus_config = function () {
	//this.page.url = 'https://m.albertleatribune.com/2020/07/terry-larsen-67/';
	this.page.identifier = '742142 https://m.albertleatribune.com/?p=742142';
	this.page.title = 'Terry Larsen, 67 - Albert Lea Tribune';
};
(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');

s.src = '//albertleatribune.disqus.com/embed.js';

s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>



									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Opinion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/editorial-dont-let-mask-mandate-hurt-business-community/" title="Permalink to Editorial: Don’t let mask mandate hurt business community" rel="bookmark">Editorial: Don’t let mask mandate hurt business community</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/editorial-tribune-thumbs-281/" title="Permalink to Editorial: Tribune Thumbs" rel="bookmark">Editorial: Tribune Thumbs</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/live-united-need-for-food-services-is-expected-to-rise-next-month/" title="Permalink to Live United: Need for food services is expected to rise next month" rel="bookmark">Live United: Need for food services is expected to rise next month</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/april-jeppson-its-amazing-how-music-affects-your-mood/" title="Permalink to April Jeppson: It’s amazing how music affects your mood" rel="bookmark">April Jeppson: It’s amazing how music affects your mood</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/guest-column-supporting-the-areas-smallest-communities/" title="Permalink to Guest Column: Supporting the area’s smallest communities" rel="bookmark">Guest Column: Supporting the area’s smallest communities</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Sports</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/garcia-homers-twice-as-white-sox-pound-twins-10-3/" title="Permalink to García homers twice as White Sox pound Twins 10-3" rel="bookmark">García homers twice as White Sox pound Twins 10-3</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/zimmer-says-cook-told-him-hed-report-to-vikes-camp-on-time/" title="Permalink to Zimmer says Cook told him he&#8217;d report to Vikes camp on time" rel="bookmark">Zimmer says Cook told him he&#8217;d report to Vikes camp on time</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/tee-it-up-for-campers-golf-tourney-scheduled/" title="Permalink to Tee it Up for Campers golf tourney scheduled" rel="bookmark">Tee it Up for Campers golf tourney scheduled</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/hunters-will-have-more-opportunities-to-harvest-deer-this-season/" title="Permalink to Hunters will have more opportunities to harvest deer this season" rel="bookmark">Hunters will have more opportunities to harvest deer this season</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/2-holes-in-one-hit-at-wedgewood/" title="Permalink to 2 holes-in-one hit at Wedgewood" rel="bookmark">2 holes-in-one hit at Wedgewood</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  				<li id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widgettitle">Latest Stories</h2>
		<ul>
											<li>
					<a href="https://m.albertleatribune.com/2020/07/daily-covid-19-update-area-counties-report-new-cases-2/">Daily COVID-19 update: Area counties report new cases</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2020/07/2-more-covid-19-deaths-650-new-cases/">2 more COVID-19 deaths; 650 new cases</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2020/07/terry-larsen-67/" aria-current="page">Terry Larsen, 67</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2020/07/kathleen-mae-bennett/">Kathleen Mae Bennett</a>
									</li>
											<li>
					<a href="https://m.albertleatribune.com/2020/07/authorities-investigating-burglaries-and-other-reports/">Authorities investigating burglaries and other reports</a>
									</li>
					</ul>
		</li>

	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Local News</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/daily-covid-19-update-area-counties-report-new-cases-2/" title="Permalink to Daily COVID-19 update: Area counties report new cases" rel="bookmark">Daily COVID-19 update: Area counties report new cases</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/2-more-covid-19-deaths-650-new-cases/" title="Permalink to 2 more COVID-19 deaths; 650 new cases" rel="bookmark">2 more COVID-19 deaths; 650 new cases</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/authorities-investigating-burglaries-and-other-reports/" title="Permalink to Authorities investigating burglaries and other reports" rel="bookmark">Authorities investigating burglaries and other reports</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/couple-wears-swastika-masks-in-minnesota-walmart/" title="Permalink to Couple wears swastika masks in Minnesota Walmart" rel="bookmark">Couple wears swastika masks in Minnesota Walmart</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.albertleatribune.com/2020/07/target-to-close-on-thanksgiving-ending-black-friday-kickoff/" title="Permalink to Target to close on Thanksgiving, ending Black Friday kickoff" rel="bookmark">Target to close on Thanksgiving, ending Black Friday kickoff</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<div class="teaseStory special_sections_block">
			<h3 class="section">Special Section</h3>
      <iframe src="https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&amp;theme=theme2&amp;rows=2&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=false&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true](https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&theme=theme2&rows=2&thumbSize=large&roundedCorners=false&showTitle=false&showAuthor=false&shadow=true&effect3d=true)" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="100%" height="370"></iframe>

			<div class="more_stories">
				<h4><a href="https://www.albertleatribune.com/special-promos/" class="moreLink" rel="bookmark">More special sections</a></h4>
			</div>
		</div>

			<h3 class="section">Financials</h3>

			<div id="twitterBox300x" class="clearFix">
			<!--START theFinancials.com Content-->
			<!--copyright theFinancials.com - All Rights Reserved-->
			<iframe src='https://www.thefinancials.com/free/EXm_MarketUpdate_US.html' width='100%' marginheight='0' marginwidth='0' height='400' hspace='0' vspace='0' frameborder='no' style='margin-bottom:12px' title='US Market Update'><br /></iframe>
			<!--END theFinancials.com Content-->
			<br />
</div></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/daily-covid-19-update-area-counties-report-new-cases-2/" rel="bookmark" title="Daily COVID-19 update: Area counties report new cases">Daily COVID-19 update: Area counties report new cases</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/2-more-covid-19-deaths-650-new-cases/" rel="bookmark" title="2 more COVID-19 deaths; 650 new cases">2 more COVID-19 deaths; 650 new cases</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Cops, Courts &amp; Fires</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/authorities-investigating-burglaries-and-other-reports/" rel="bookmark" title="Authorities investigating burglaries and other reports">Authorities investigating burglaries and other reports</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/couple-wears-swastika-masks-in-minnesota-walmart/" rel="bookmark" title="Couple wears swastika masks in Minnesota Walmart">Couple wears swastika masks in Minnesota Walmart</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/target-to-close-on-thanksgiving-ending-black-friday-kickoff/" rel="bookmark" title="Target to close on Thanksgiving, ending Black Friday kickoff">Target to close on Thanksgiving, ending Black Friday kickoff</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/virus-vaccine-put-to-final-test-in-thousands-of-volunteers/" rel="bookmark" title="Virus vaccine put to final test in thousands of volunteers">Virus vaccine put to final test in thousands of volunteers</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Cops, Courts &amp; Fires</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/man-injured-in-rollover-near-twin-lakes/" rel="bookmark" title="Man injured in rollover near Twin Lakes">Man injured in rollover near Twin Lakes</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/white-house-pushes-narrow-virus-aid-pelosi-blasts-gop-delay/" rel="bookmark" title="White House pushes narrow virus aid; Pelosi blasts GOP delay">White House pushes narrow virus aid; Pelosi blasts GOP delay</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/daily-covid-19-update-area-counties-report-new-cases/" rel="bookmark" title="Daily COVID-19 update: Area counties report new cases">Daily COVID-19 update: Area counties report new cases</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/torrential-rain-causes-flooding-in-south-central-minnesota/" rel="bookmark" title="Torrential rain causes flooding in south-central Minnesota">Torrential rain causes flooding in south-central Minnesota</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/minnesota-surpasses-50000-positive-covid-19-cases/" rel="bookmark" title="Minnesota surpasses 50,000 positive COVID-19 cases">Minnesota surpasses 50,000 positive COVID-19 cases</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/testing-supply-chain-in-minnesota-re-emerges-as-concern/" rel="bookmark" title="Testing supply chain in Minnesota re-emerges as concern">Testing supply chain in Minnesota re-emerges as concern</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Health Updates</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/minnesota-sees-return-of-vaping-related-lung-injuries/" rel="bookmark" title="Minnesota sees return of vaping-related lung injuries">Minnesota sees return of vaping-related lung injuries</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/albert-lea-school-board-begins-talks-on-referendum/" rel="bookmark" title="Albert Lea school board begins talks on referendum">Albert Lea school board begins talks on referendum</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Arts &amp; Culture</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/new-exhibits-goal-is-to-help-people-escape/" rel="bookmark" title="New exhibit’s goal is to help people escape">New exhibit’s goal is to help people escape</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections &amp; Campaigns</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/candidate-qa-minnesota-house-of-representatives-district-27a/" rel="bookmark" title="Candidate Q&#038;A: Minnesota House of Representatives District 27A">Candidate Q&#038;A: Minnesota House of Representatives District 27A</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Gallery</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/tractors-cruise-through-area/" rel="bookmark" title="Tractors cruise through area">Tractors cruise through area</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/mayo-clinic-express-care-locations-in-albert-lea-and-austin-to-reopen/" rel="bookmark" title="Mayo Clinic Express Care locations in Albert Lea and Austin to reopen">Mayo Clinic Express Care locations in Albert Lea and Austin to reopen</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Cops, Courts &amp; Fires</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/court-dispositions-july-21-22-2020/" rel="bookmark" title="Court Dispositions: July 21-22, 2020">Court Dispositions: July 21-22, 2020</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/drive-thru-rubys-pantry-scheduled-for-august/" rel="bookmark" title="Drive-thru Ruby’s Pantry scheduled for August">Drive-thru Ruby’s Pantry scheduled for August</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/mda-expands-minnesota-farm-rural-helpline/" rel="bookmark" title="MDA expands Minnesota farm, rural helpline">MDA expands Minnesota farm, rural helpline</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/nami-will-host-a-virtual-walk/" rel="bookmark" title="NAMI will host a virtual walk">NAMI will host a virtual walk</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/mda-receives-farm-to-school-grant-from-usda/" rel="bookmark" title="MDA receives Farm to School grant from USDA">MDA receives Farm to School grant from USDA</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.albertleatribune.com/2020/07/farmers-eligible-for-debt-relief/" rel="bookmark" title="Farmers eligible for debt relief">Farmers eligible for debt relief</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
														<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.albertleatribune.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://m.albertleatribune.com/category/lifestyles/" title="" rel="bookmark"><span>Arts &amp; Culture</span></a></li>
								<li><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea" title="" rel="bookmark"><span>Classifieds</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
														<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://m.albertleatribune.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://m.albertleatribune.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://m.albertleatribune.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://m.albertleatribune.com/services/policies/#termsofuse" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://m.albertleatribune.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://m.albertleatribune.com/services/submit-a-photo/" title="" rel="nofollow">Submit a photo</a></li>
																							</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2020, Albert Lea Tribune</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1592988658"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1592988658"></script>
        <script src="https://www.albertleatribune.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1592988658"></script>

        
        
				
<script type="text/javascript">tb_pathToImage = "https://m.albertleatribune.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.albertleatribune.com/wp-includes/js/thickbox/tb-close.png";</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.albertleatribune.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/thickbox/thickbox.js?m=1592863976g'></script>
<script src='https://www.albertleatribune.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6'></script>
<script>
var pollsL10n = {"ajax_url":"https:\/\/m.albertleatribune.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.albertleatribune.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' src='https://m.albertleatribune.com/wp-includes/js/wp-embed.min.js?m=1592863976g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202031.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'173113710',post:'742142',tz:'-5',srv:'m.albertleatribune.com'} ]);
	_stq.push([ 'clickTrackerInit', '173113710', '742142' ]);
</script>
				</div><!-- END undertone -->
        				<script id="dsq-count-scr" src="//albertleatribune.disqus.com/count.js" async></script>
            </body>
</html>